اخبار, ووکامرس

PHP 7.2+ برای ووکامرس 6.5 ضروری است

PHP 7.2+ برای ووکامرس 6.5 ضروری است

مدتی می‌گذرد که حداقل نسخه PHP موردنیاز ووکامرس به 7.0 به‌روزرسانی شده است و زمان به‌روزرسانی دیگری فرا رسیده است. ووکامرس برای اجرا به PHP 7.2 یا جدیدتر برای اجرای نسخه 6.5 ووکامرس نیاز دارد که قرار است در می 2022 منتشر شود.

چرا این تغییر؟

اکوسیستم PHP به سرعت در حال تغییر است. PHP 8.0 و 8.1 تنها نسخه‌های PHP هستند که در زمان نوشتن به طور فعال نگهداری می‌شوند. PHP 7.4 در حالت “فقط اصلاحات امنیتی” است، در حالی که PHP 7.3 دیگر از دسامبر 2021 پشتیبانی نمی شود. به دلایل عملکرد و امنیتی، وردپرس حداقل PHP 7.4 را توصیه می کند و این ملاحظات برای یک سایت تجارت الکترونیک بسیار مرتبط تر است.

ووکامرس همچنین به تعدادی از برنامه های شخص ثالث متکی است که بسیاری از آنها به تدریج پشتیبانی از نسخه های قبلی PHP را متوقف می کنند.

طبق آمار، 7.2 قدیمی ترین نسخه با تعداد زیادی نصب فعال ووکامرس است.

اگر ارتقا ندهید چه اتفاقی می افتد؟

اگر زمانی که ووکامرس 6.5 منتشر شد، سرور شما همچنان PHP 7.0 یا 7.1 را اجرا کند، نمونه ووکامرس شما به کار خود ادامه می دهد، اما نمی توانید ووکامرس 6.4 را ارتقا دهید. (یا هر نسخه جدیدی که پس از آن منتشر شد).

برای اینکه سایت های ووکامرس خود را آپدیت، عملکرد و ایمن نگه دارید، اکیداً توصیه می کنیم سرورهای خود را به PHP 7.4 آپدیت کنید.

4.7/5 - (3 امتیاز)

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *